Cisco 2960交换机刷屏Native VLAN mismatch discovered的解决方法

原本的配置

interface GigabitEthernet1/0/22
 switchport access vlan 3099
interface GigabitEthernet1/0/48
 switchport mode trunk
 switchport nonegotiate

Cisco 2960交换机刷屏Native VLAN mismatch discovered的解决方法

经过分析,主要原因是:cisco2960交换机下面接有没有做过任何配置的cisco交换机引起,造成CDP-4-NATIVE_VLAN_MISMATCH日志和Native VLAN mismatch discovered报错。
解决方法:
在cisco2960交换机报警端口,通过添加命令 no cdp enable解决

interface GigabitEthernet1/0/22
 switchport access vlan 3099
 switchport mode access
 switchport protected
 switchport block multicast
 switchport block unicast
 no cdp enable
L2SW011#show interfaces GigabitEthernet1/0/22
GigabitEthernet1/0/22 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 5478.1aae.f416 (bia 5478.1aae.f416)
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 136000 bits/sec, 94 packets/sec
  5 minute output rate 590000 bits/sec, 106 packets/sec
     24543289 packets input, 3190008079 bytes, 0 no buffer
     Received 513101 broadcasts (306930 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 306930 multicast, 0 pause input
     0 input packets with dribble condition detected
     73494813 packets output, 51768728834 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     372 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

L2SW011#show interfaces vlan 3099
Vlan3099 is up, line protocol is up
  Hardware is EtherSVI, address is 5478.1aae.f441 (bia 5478.1aae.f441)
  Internet address is 10.199.100.11/8
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 10:41:41, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 14000 bits/sec, 22 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1086500 packets input, 92145908 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     63 packets output, 4109 bytes, 0 underruns
     0 output errors, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
L2SW011#
lookback
  • 本文由 发表于 2020年11月6日02:38:24
  • 除非特殊声明,本站文章均为原创,转载请务必保留本文链接
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: